Hellfire103 to Programmer [email protected]English • 2 months agoTIFU by not using objects in my object-oriented programming courseworklemmy.caimagemessage-square24fedilinkarrow-up180arrow-down110cross-posted to: [email protected]tifu
arrow-up170arrow-down1imageTIFU by not using objects in my object-oriented programming courseworklemmy.caHellfire103 to Programmer [email protected]English • 2 months agomessage-square24fedilinkcross-posted to: [email protected]tifu
minus-square@[email protected]linkfedilink4•2 months agoDon’t you need to declare new Balls() first? Or do you suck() Balls static?
minus-squarexigoilinkfedilinkEnglish7•edit-22 months agoBallsFactory ballsFactory = new BallsFactory(); ballsFactory.setSuckable(true); Balls balls = ballsFactory.create();
minus-square@whats_all_this_thenlink10•edit-22 months agoAll of this is okay, but it’s not production ready. This is what real production code looks like: SuckableFactory suckableFactory = new SuckableFactory(); Suckable balls = suckableFactory .setShape(SuckableShapes.round) .setCount(2) .create(); SuctionProvider mouth = SuctionProvider.getInstance(); SuckerFactory suckerFactory = new SuckerFactory(); Sucker sucker = SuckerFactory.create(): sucker.setSuctionProvider(mouth); sucker.setSuckable(balls); sucker.setIntensity(SuckerSuctionIntensities.medium); sucker.suckSuckable();
minus-square@[email protected]linkfedilink3•2 months agoOr I didn’t using the correct naming convention!
minus-square@[email protected]linkfedilink2•2 months agoActually, it would be OOP.suck(ddplf.getBalls())
Good, OOP can suck my balls
Balls.suck() is the correct syntax.
Don’t you need to declare new Balls() first? Or do you suck() Balls static?
BallsFactory ballsFactory = new BallsFactory(); ballsFactory.setSuckable(true); Balls balls = ballsFactory.create();
All of this is okay, but it’s not production ready. This is what real production code looks like:
SuckableFactory suckableFactory = new SuckableFactory(); Suckable balls = suckableFactory .setShape(SuckableShapes.round) .setCount(2) .create(); SuctionProvider mouth = SuctionProvider.getInstance(); SuckerFactory suckerFactory = new SuckerFactory(); Sucker sucker = SuckerFactory.create(): sucker.setSuctionProvider(mouth); sucker.setSuckable(balls); sucker.setIntensity(SuckerSuctionIntensities.medium); sucker.suckSuckable();
Python port:
from ballsucker import suck suck()
Or I didn’t using the correct naming convention!
Actually, it would be
OOP.suck(ddplf.getBalls())