• Eager Eagle
    link
    English
    24
    edit-2
    1 year ago

    Unless they’re indices, do yourself a favor and use meaningful names instead.

    I avoid index iterations the most I can tbh. And for nested loops,i and k is more readable.

    • @[email protected]
      link
      fedilink
      121 year ago

      Even for indexes I do index or something more specific for what it’s indexing. Any simple iteration I just do map or each so the only time I ever need to actually index things is for more complex scenarios in which case it’s worth it to have better names. Also with modem IDEs, auto complete is really good so you don’t need to write a full variable name more than once.

      • Eager Eagle
        link
        English
        3
        edit-2
        1 year ago

        that’s good too. I recommended k over j if using single letters, but I actually tend to use idx when using indices, and more descriptive idx_this, idx_that for rare index-based nested loops.

    • Alien Nathan Edward
      link
      fedilink
      61 year ago

      When I was a baby coder back in the 90s we were taught that these names were meant to save space in the symbol table because at one time space was so limited that naming your variable n rather than numElementsInArray would have an impact

    • Fonzie!
      link
      fedilink
      1
      edit-2
      1 year ago

      Even then,

      for (int index = 0; index < 10; index++)
      

      all the way.