• @fubo
    link
    741 year ago

    Fortran, really.

    In Fortran, variables beginning with the letters i through n have integer type by default, whereas all other letters imply a real-number (floating-point) variable. You can change this by declaring a type, but using i for a real is non-obvious.

    (Hence the old joke, “God is real — unless declared integer.”)

    • Eager Eagle
      link
      English
      32
      edit-2
      1 year ago

      idk, this arbitrary i-n range behaving differently than other variables sounds like a terrible source of weird bugs to me. I don’t think variable names should ever change a program’s behavior.

      edit:

      Many old Fortran 77 programs uses these implicit rules, but you should not! The probability of errors in your program grows dramatically if you do not consistently declare your variables.

      source

      • @[email protected]
        link
        fedilink
        291 year ago

        This comes from early years, when FORTRAN was introduced and the programmers needed to save space in the punch cards. Today, to avoid this possible source of bugs, you usually state “implicit none” in the preamble.

        • @[email protected]
          link
          fedilink
          201 year ago

          So I’ve been an engineer doing code ports to newer versions of Fortran. I never knew why that was at the top of every file. Thank you.

  • @[email protected]
    link
    fedilink
    561 year ago

    in programming, and in mathematics, it’s always been weird to me that frequently paired variables are basically the most easily confused for one another pairs, especially when written quickly or sloppily.

    • i and j
    • x and y
    • m and n
    • Eager Eagle
      link
      English
      231 year ago

      exactly, this is so annoying. I don’t know by first-hand experience, but I also think p and q are confusing for dyslexic people.

        • @[email protected]
          link
          fedilink
          61 year ago

          u and v were so difficult for me to differentiate in handwriting. My handwriting is not that pretty and the difference between a round bottom and a sharp bottom is not that big when stressed in an exam.

      • @BleatingZombie
        link
        51 year ago

        I’m not dyslexic, but I always had to write P and Q capitalized on my truth tables to not absent-mindedly get them switched

      • Oliver Lowe
        link
        fedilink
        11 year ago

        When travelling in places where Latin script is not official (e.g. Middle East, Asia), I notice many mix-ups of p q and b. I always wondered how this would impact their ability to learn to program.

    • @affiliate
      link
      41 year ago

      the worst is when you have to deal with v and ν (greek “nu”). add in the wedge symbol ∨ and things can get painful.

  • @[email protected]
    link
    fedilink
    331 year ago

    I always like to joke in coding interviews that I really like to make variable names as long as I can so they are very precisely named. Then when I get to a double nested loop I hit them with iterator and jiterator instead of I and j

  • Eager Eagle
    link
    English
    24
    edit-2
    1 year ago

    Unless they’re indices, do yourself a favor and use meaningful names instead.

    I avoid index iterations the most I can tbh. And for nested loops,i and k is more readable.

    • @[email protected]
      link
      fedilink
      121 year ago

      Even for indexes I do index or something more specific for what it’s indexing. Any simple iteration I just do map or each so the only time I ever need to actually index things is for more complex scenarios in which case it’s worth it to have better names. Also with modem IDEs, auto complete is really good so you don’t need to write a full variable name more than once.

      • Eager Eagle
        link
        English
        3
        edit-2
        1 year ago

        that’s good too. I recommended k over j if using single letters, but I actually tend to use idx when using indices, and more descriptive idx_this, idx_that for rare index-based nested loops.

    • Alien Nathan Edward
      link
      fedilink
      61 year ago

      When I was a baby coder back in the 90s we were taught that these names were meant to save space in the symbol table because at one time space was so limited that naming your variable n rather than numElementsInArray would have an impact

    • Fonzie!
      link
      fedilink
      1
      edit-2
      1 year ago

      Even then,

      for (int index = 0; index < 10; index++)
      

      all the way.

  • @[email protected]
    link
    fedilink
    15
    edit-2
    1 year ago

    i for index or iteration. Using j, k, l… in loops signals (imho) that there is most likely an outer loop and the one using j, k, l are nested. x and y of course are carthesian coordinates . n is used as amount of substance in SI-unit-system, m is mass, maybe thats why it is used as amount of items in a set (Menge).

    Programming computers have started to solve mathematical problems and math already used these symbols for centuries(?), so why you should change them? They are well established even in simple school mathematics. And at the end of the day a computer is nothing more than a calculator.

    • Eager Eagle
      link
      English
      11 year ago

      why you should change them

      Readability and maintainability, mostly. They are one character long mostly to help handwriting compact formulas, but their pros end there. For software, though:

      “Programs are meant to be read by humans and only incidentally for computers to execute”

      • @Zeth0s
        link
        11 year ago

        For readability the loop has to be short, so it is not really a problem, and it is also clear the iterated variable.

        Long loops where the iterated variable is called far from the loop are anyway very bad for readability. There is a much worse problem in that code than i and j

    • Hydroel
      link
      61 year ago

      Whay kind of savage names their loop index x?

      • @[email protected]
        link
        fedilink
        21 year ago

        Not the index, the variable in the for loop. Index is always i because it can be unless it’s a nested loop.

      • @Zeth0s
        link
        1
        edit-2
        1 year ago

        You’ll receive a visit from ML engineers and data scientists asking if you know the lords and saviors X, y

      • @j4k3
        link
        English
        11 year ago

        for x, twit in bird:

  • @ale
    link
    10
    edit-2
    10 months ago

    deleted by creator

    • @[email protected]
      link
      fedilink
      41 year ago

      I’ve hardly ever looped over indices after college. For-each loops solve 99% of real-world problems in a better way.

  • @[email protected]
    link
    fedilink
    4
    edit-2
    1 year ago

    Usually variables like that can be avoided with itterators nowadays. If they can’t I like to use idx, if they are nested I name them after what they index, like idx_rows, idx_cols.

  • UnfortunateShort
    link
    31 year ago

    Ask the mathematicians, they started it. And I don’t question their wisdom because a) maths can be very scary and b) I like Arch almost as much as being dominated

  • @nitefox
    link
    21 year ago

    Very relevant to Linux and a very original, funny, meme too I see