Both zig and go use the dot operator, but I find the ‘::’ operator much more readable.

Vec::new();

Makes it clear that were accessing a static method belonging to the Vec struct/namespace.

Vec.new()

Makes it seem like Vec is an object with a ‘new’ method.

Am I alone in thinking this?

  • Pyro
    link
    English
    206 months ago

    I used to only use C#, and I liked the simplicity of only using one symbol to access any prop/field/method. But now I’ve used Rust for a while I do prefer separating the two for the same reasons you mentioned.

    So no, you’re not alone. Even cross-lang!