Short but honestly good advise to rather pull boolean checks apart and re-group them as they make sense in the context of the given situation you’re checking for.

I started doing this when building an alert-check system for the company I’m working for right now, and it really helps organize what is a pre-condition, what a syntactical requirement, etc etc.

  • @soloner
    link
    227 months ago

    I was expecting something more profound. Isn’t this just the concept of using variables to keep code readable? Not a new concept and likely one most devs learn early on.

    • @overcast5348
      link
      217 months ago

      I’ve had at least one code reviewer ask me to put all the logic in the if ... line rather than use a variable or two in order to “simplify code by reducing the number of variables.”

      At the very least, this article helped me confirm my own bias of “that guy is a moron” and I can send this article to him the next time he reviews my code.

      • @[email protected]
        link
        fedilink
        127 months ago

        Yes, you need to push back on those people. They’re the type that get high on code golf and end up writing unmaintainable one-liners measured in kilobytes for fun.

      • @Valmond
        link
        17 months ago

        Well it actually depends.

        Does it make the code more readable? Like you have several if statements using the same things (and/or else if)? Yeah then it’s probably good.

        If you have an if (work.lengt() == 0 && stacked_work.length() == 0) and that’s it, probably not. Depending of whats happining then of course.

        Be creative guys! But also dont be too creative :-) Think about the poor coder doing something with all that in a year or two, let’s make his life less miserable (It’s probably you, too).

        • @overcast5348
          link
          27 months ago

          “it actually depends”

          Yes, it depends. But in this scenario we’re not discussing if statements with one or two conditions. We’re exclusively discussing multiple complicated conditions. :)

          • @Valmond
            link
            17 months ago

            Well thei it is probably almost always good to clear things up :-) !

      • @[email protected]
        link
        fedilink
        17 months ago

        I review a ton of code and have a bunch reviewed in turn. I don’t remember that last time I’ve had this come up. Either direction really. I guess I’m lucky. We just split naturally in similar places.

      • @[email protected]
        link
        fedilink
        English
        17 months ago

        I guess this is go, and I don’t know what the scoping is. In C++ I also suggest putting as much in the if as possible, because it limits the scope of the variables.

    • @[email protected]
      link
      fedilink
      37 months ago

      This is “Testing on the Toilet” which are short flyers that are posted in bathrooms at Google. They aren’t typically meant to be particularly profound, just to remind people of common code patterns that can be written more clearly or other reminders that are good to keep in mind.

  • @breadsmasher
    link
    English
    15
    edit-2
    7 months ago

    Good advice. The few pages of blog posts I have read are a really great read

    • @cbarrick
      link
      English
      67 months ago

      The entire TotT series is pretty good.

  • kbin_space_program
    link
    fedilink
    107 months ago

    Yes, I’ve been doing this for years. It’s great for both code readability as well as debugging.

    • Carighan MaconarOP
      link
      137 months ago

      Vegetable is probably meant in the culinary use here, not in the biological one. And like with many such terms the two do overlap but not entirely.

      • @[email protected]
        link
        fedilink
        17 months ago

        I don’t think a lot of people think that mushrooms are vegetables in any sense. If you check culinary lists of vegetables, they don’t contain edible fungi.

        • @Feathercrown
          link
          English
          77 months ago

          I’d consider them vegetables for cooking purposes

  • @[email protected]
    link
    fedilink
    77 months ago

    Good advice, clear, simple and to the point.

    Stated otherwise: “whenever you need to add comments to an expression, try to use named intermediate variables, method or free function”.

    • @[email protected]
      link
      fedilink
      87 months ago

      Sometimes this can help, but lately I’ve been running into the opposite problem where people have been following this advice to such a degree that one cannot ever figure out what is going on without having to constantly jump around to find the actual code involved in doing something.

      • Carighan MaconarOP
        link
        37 months ago

        Ah I hate that, too. It speaks of bad abstraction, over eager abstraction or unnecessary coupling that is the hidden behind this. Difficult to fix though without essentially starting over.

      • @[email protected]
        link
        fedilink
        27 months ago

        I absolutely agree that method extraction can be abused. One should not forget that locality is important. Functionnal idioms do help to minimise the layer of intermediate functions. Lamda/closure helps too by having the function much closer to its use site. And local variables can sometime be a better choice than having a function that return just an expression.

  • @[email protected]
    link
    fedilink
    27 months ago

    I do OOP because it naturally encourages me to do this sort of thing: abstract complicated logic into inspectable, reusable, testable properties of an object.