• @serpineslair
      link
      English
      142 months ago

      Makes it even better that I’m on mobile so the text wrapped half way through a word.

    • JohnEdwa
      link
      fedilink
      132 months ago

      I can read that without any issues whatsoever.

      But. If. You. Put. Periods. Between. Each. Word. My brain will force a pause between every single one and I can’t override it.

      • @[email protected]
        link
        fedilink
        English
        12 months ago

        Forever Ago I Ran A Minecraft Server And 2 Friends Joined And One Typed Everything They Said Like This and the other managed to misspell every single word with more than 2 letters in it. They misspelled the word “the!” According to Sir Capitalizes Every Single Word, its just much easier to type that way, which raised far more questions than answers…

        • @[email protected]
          link
          fedilink
          English
          4
          edit-2
          2 months ago

          I decided to be wrong because the correct joke would be too convoluted. I’ll work on that implementation and then you can inject it at runtime via reflection.

          • @[email protected]
            link
            fedilink
            32 months ago

            Thanks for preparing your comment for my dependency injection! I agree that refactorability of comments is preferable over prematurely optimizing for performance.

            • @[email protected]
              link
              fedilink
              English
              22 months ago

              First it needs to work, then it needs to work well, and finally it may or may not work quickly. Along the way, it should also be humorously weird.

    • qaz
      link
      22 months ago

      That page is giving me a 403

    • BombOmOm
      link
      English
      1
      edit-2
      2 months ago

      I’m still annoyed with how verbose Objective-C is. Just check out what one has to do to create and concatenate a string. Madness:

          NSString * test = [[NSString alloc] initWithString:@"This is a test string."];
          NSString * test2 = [test stringByAppendingString:@" This value is appended."];
      

      And god forbid you want to concatenate two things to a string:

          NSString * test3 = [test1 stringByAppendingString:[test2 stringByAppendingString:@" Adding a third value."]];
      
      • @[email protected]
        link
        fedilink
        10
        edit-2
        2 months ago

        In Oct’23 a basic Text widget with Subprocess to run shell commands allowed me to take my command line fu into a different arena because Tkinter gave me special tricks. This tool (shell functions) allows me to type up GUI apps or any Python script with less effort, for my fingers and brain.

        wc newide; ksh newide | wc

        513 1671 11018 newide in pnk

        604 1987 29867 newide in python

        The blocks of color are capital letters colored using tkinter methods (tag_add & tag_configure) with a bg and fg of the same color to make it look like a lego block, it’s all ASCII. On the right, an idle clicker game/toy made with pnk.lang, also just ASCII/UTF-8. The IDE you see in the pic also was coded using functional shell language I call pnk.lang and the original first iteration of this specification is in the legacy folder in the repo below. Just me learning how to code faster in Python but in shell but in neither at this point.

        https://github.com/dislux-hapfyl/pynksh

        https://www.reddit.com/r/pnk/

        Don’t be put off by Ksh because Bash can also interpret it, since it’s just shell functions that print Python code. But I have plans to use an Xbox controller so I can move away from building with the keyboard at piecemeal rates. I will do this by abstracting away identifiers and all data we use as engineers into “dictionaries” to then transform it into a spatial system. I already done this first step! Using a basic grid with a maximum of 10 rows x 3 cols, indexing row[0-9] col[0-2], as you see there on the left side, and by using a letter I then categorize the functions of pnk(shell+python) so I can have 30 x 26[a-z] available slots; a00 b11 k22 and so on…by making it a visual shortcut that reduces cognitive load and typing for me.

        Take a closer look at my repo without dismissing it too quickly. It could seem unnecessary but maybe someone else can see what I have made as useful and how we gonna take it to higher levels of abstraction and create a new realm for making computer applications in an abstract game/IDE of art and code. Perhaps it’s that creator effect that happens when you make something for the first time that makes me see its future utility and appeal. All this was made incrementally using my own software I built from scratch. I do have a great vision and would love to speak to anyone who is interested. I also demonstrate the utility of this small tool on youtube[link in repo]. Thanks.

          • @[email protected]
            link
            fedilink
            1
            edit-2
            2 months ago

            I write python in shell. Literally. I made a shell function file (pnk.lang) that prints correct python code. The capital letters in the shell function’s name, my Tkinter IDE turns into color as you see above. So I let the color (capital letter) abstract away indentation for my brain. The second letter is for category of python code according to me. Again using color to allow me to think. I dont like Python syntax. I looks ugly to me. So I made this tool to make coding colorful, succint and fun for me. It reduces my eye strain among many other personal benefits.

            S=self

            E=echo

            #indentation

            #Z=“” #0

            Y=" " #3

            X="$Y$Y " #7

            W="$Y$X " #11

            V="$Y$W " #15

            U="$Y$V " #19

            YDfd() {

            typeset z="$1"
            
                typeset nn="$2"
            
            typeset cc="$3" 
            
            if [[ $z == z ]]; 
            
            then
            
            	$E "$Y def $nn(${S}$cc):"
            
            else
            
            	$E "$Y def $nn($cc):"
            
            fi
            

            }

            YDdefe() {

            typeset fn="$1"
            
            YDfd z $fn ,e=None
            

            }

            YDdefe addNew

            XIcv $ap Pnk

            XFpk $ap 1 both

            XFfc zz pw.add $ap

            turns into

            def addNew(self,e=None):
                self.appinstance = Pnk(self,)
                self.appinstance.pack(expand=1,fill="both",padx=2,pady=2,)
                self.pw.add(self.appinstance)
            
        • @[email protected]
          link
          fedilink
          22 months ago

          Ok I don’t completely get the use case but that’s…impressive. Thanks for the detailed explanation and good luck moving it forward

  • @[email protected]
    link
    fedilink
    English
    132 months ago

    My ASDV professor has two moods: He either names variables like this post, Or he names variables pp (for pointer pointer)

    • @robojeb
      link
      22 months ago

      Fuck for some reason pp is giving me flashbacks to having to write using Hungarian notation variable names.

  • Enoril
    link
    fedilink
    10
    edit-2
    2 months ago

    I don’t see the benefit of this long naming convention…

    It still allow bug to exist… like the fact that, with this code, the player can still play with 0 Hp.

    Should have been better to put a “if(health <= 0)” instead of “< 0”

    • @stockRot
      link
      22 months ago

      It sounds like the only concern you have with code is its bugginess, which is short sights. This is unfortunately better documented code than stuff I’ve seen in production. Obviously no one should do this, but let’s not act like there’s no benefit

      • Enoril
        link
        fedilink
        12 months ago

        Indeed, you can achieve a better result with less verbose naming convention. And choose better variable name to make it obvious than 0 Hp is death. While i don’t like having too verbose variable name (as it impacts the readability and quick understanding of the function), i’m not against that for the function name… without going too far of course!

        Best is too have proper datamodeling of the object manipulated on top of some classic basic comments. Good interface contract is also a minimum. Best is to have full datamodeling of all the services, objects, in and out interactions between them, etc.

        Documentation is a mandatory piece of the code delivery (with tests being the other important part) far too much forgotten if you don’t enforce it on your teams.

    • @joshfaulkner
      link
      22 months ago

      I asked this question on this post on a different instance, but would there be issues being that the code compares a float to integer zero “0”?

      • BombOmOm
        link
        English
        2
        edit-2
        2 months ago

        Since the health is a float, yeah, it can create issues. A health of 0.000000001 is greater than zero, but that would almost assuredly be displayed to the user as simply 0, causing player confusion. The easiest solution is to have health and damage always be integers. A less great solution is to use a non-floating point decimal format. If such doesn’t exist in your language, you can emulate one by having health and damage both always be integers, but move the decimal point over, say two points, when displaying to the user.